Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 3 months ago. Jul 31, 2019 - 06:59 SAST
Investigating
Withdrawals in Malaysia will not be processed on 30 July 2019 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 31 July 2019.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted 3 months ago. Jul 29, 2019 - 08:36 SAST
This incident affected: Bank deposits and withdrawals (Malaysia).