Public Bank deposits in Malaysia
Incident Report for Luno
Resolved
We are yet to hear back from Public Bank, customers may still be unable to deposit MYR to their Luno Wallet due to an issue with Public Bank.

Updates will be made available via our Help Centre https://www.luno.com/help/en/articles/11000078475
Posted Nov 25, 2019 - 04:07 UTC
Update
Unfortunately we're still waiting for feedback from Public Bank, we'll have an update posted as soon as it's available to us.
Posted Nov 19, 2019 - 07:28 UTC
Identified
Some customers may see an error on their banking platform from Public Bank when trying to make a deposit to their Luno MYR wallet. We're reaching out to the bank to resolve the issue, please make use of a different bank account, one that is in your name, to make a deposit to your MYR wallet.

Withdrawals to Public Bank customers are still functioning as normal.

Updates to follow.
Posted Nov 14, 2019 - 11:38 UTC