Slow deposits via PayU in South Africa
Incident Report for Luno
Resolved
PayU deposits are now being processed successfully.
Posted Oct 08, 2021 - 08:37 UTC
Update
Unfortunately deposits made via PayU remain slow, we're querying this urgently with PayU.
Thanks for your patience.
Posted Oct 07, 2021 - 10:14 UTC
Identified
We've identified an issue with PayU deposits taking longer than normal to clear due to an unexpected change with PayU. Our team is working closely with PayU to see this resolved as quickly as possible.
Posted Oct 07, 2021 - 08:35 UTC