Delayed bank withdrawal in South Africa
Incident Report for Luno
Resolved
Withdrawals are being processed according to schedule.

Thank you.
Posted Sep 25, 2020 - 06:06 UTC
Identified
Withdrawals in South Africa will not be processed on 24th of September due to the public holiday. Unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 25th of September.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Sep 23, 2020 - 15:55 UTC