Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 2 months ago. Jun 17, 2019 - 16:47 UTC
Identified
There will be a slight delay with Nigerian bank withdrawals requested on 17 June 2019. This is a temporary incident which we hope to see resolved during the day. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022934

Updates to follow.
Posted 2 months ago. Jun 17, 2019 - 09:17 UTC