Order book update delays on the exchange
Incident Report for
Luno
Monitoring
We are no longer seeing delays. We will monitor for additional issues.
Posted
Oct
14
,
2025
-
11:19
UTC
Update
Our Team is still working on this as a priority
Customers are experiencing a delay in order book updates when using the Exchange.
We apologise for any inconvenience caused and thank you for your patience.
Posted
Oct
13
,
2025
-
14:49
UTC
Identified
We have identified an issue that's causing delayed order book updates on the exchange.
Customers may experience a delay in order book updates when using the exchange.
Our team is working on this as a priority
Updates to follow.
Posted
Oct
13
,
2025
-
11:43
UTC
×
Subscribe to Incident
Subscribe to updates for
Order book update delays on the exchange
via . You'll receive .