Delayed NG verification
Incident Report for Luno
Resolved
This incident has been resolved and Nigerian verifications are proceeding as normal.

Thank you for your patience.
Posted Nov 11, 2021 - 14:53 UTC
Investigating
We are currently looking into an issue causing delays in the verification of Nigerian customers.
Posted Nov 10, 2021 - 13:00 UTC
This incident affected: Help & account verification (Account verification).