Bank withdrawals in South Africa
Incident Report for Luno
Resolved
Withdrawals are being processed are normal.
Posted 5 months ago. May 02, 2018 - 06:25 UTC
Identified
Withdrawals in South Africa will not be processed on 27 April and 1 May 2018 due to the public holidays, unfortunately banks do not process withdrawals over weekends or public holidays.

Withdrawals requested will be processed on 2 May 2018.
Withdrawals requested before 8am on 30 April will still be processed on 30 April 2018.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted 5 months ago. Apr 26, 2018 - 07:12 UTC