Degraded performance
Incident Report for Luno
Resolved
Load levels have returned to normal, this has now been fully resolved.

Thanks for everyone's patience.
Posted Jul 26, 2020 - 15:33 UTC
Identified
We've identified the problem and are working on a fix.
Posted Jul 26, 2020 - 12:17 UTC
Investigating
Due to extreme market volatility, some systems are seeing a degraded performance. Our engineers are aware and working to bring load levels back to normal.

This will affect the app, some website performance and the Exchange.
Updates to follow.
Posted Jul 26, 2020 - 10:23 UTC