Slow cryptocurrency sends and receives
Incident Report for Luno
Resolved
BTC, XRP, LTC, BCH and USDC sends and receives have returned to normal.

We apologise for any inconvenience.
Posted Apr 01, 2021 - 10:53 UTC
Investigating
BTC, XRP, LTC, BCH and USDC send and receives transactions may be slow for some customers, we're working on this as a priority.

Updates to follow.
Posted Apr 01, 2021 - 10:32 UTC
This incident affected: Crypto sends and receives (BTC, BCH, XRP, LTC, USDC).