Paystack deposits in Nigeria
Incident Report for Luno
Resolved
This incident has been resolved.
Posted 8 days ago. Oct 09, 2019 - 11:16 SAST
Investigating
Our team are investigating an issue with Paystack deposits affecting customers in Nigeria. Please make use of an alternative payment method by following the deposit screen.

Updates to follow soon.
Posted 8 days ago. Oct 09, 2019 - 09:28 SAST
This incident affected: Bank deposits and withdrawals (Nigeria).