Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Feb 03, 2021 - 11:53 UTC
Identified
There may be temporary delays with Malaysia withdrawals requested from 28th January 2021. We’re working with the bank to see this resolved soon.

We will attempt to release the withdrawals during the next release. You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934
Posted Feb 02, 2021 - 01:52 UTC