careers.luno.com is unavailable
Incident Report for Luno
Resolved
We aren't seeing further issues, thanks again for your patience.
Posted Apr 15, 2024 - 09:18 UTC
Monitoring
Our Careers site is back up, we're monitoring for any potential further issues.
Thanks for your patience.
Posted Apr 15, 2024 - 08:23 UTC
Identified
We're aware of some issues affecting the Careers page, our team is on top of it and working to resolve the issue as quickly as possible.
Posted Apr 15, 2024 - 07:06 UTC