Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
All services have returned to normal.
Posted 2 months ago. Jul 10, 2019 - 13:13 SAST
Investigating
Due to technical issues experienced, withdrawals requested on 9 July 2019 will be delayed.

Requested withdrawals will be processed on 10 July 2019.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted 2 months ago. Jul 09, 2019 - 10:29 SAST
This incident affected: Bank deposits and withdrawals (Malaysia).