Scheduled Maintenance
Incident Report for Luno
Resolved
The scheduled maintenance has been completed.
Posted Aug 25, 2020 - 19:32 UTC
Investigating
We will be undergoing scheduled maintenance starting at 7pm UTC which may affect deposits during this time.

We’ll post an update once the maintenance is complete..

Thank you for your understanding.
Posted Aug 25, 2020 - 19:02 UTC