FPX Deposits unavailable in Malaysia on 9th Nov 2pm to 3pm
Incident Report for Luno
Resolved
FPX deposits are now being processed as scheduled. Thank you
Posted Nov 09, 2021 - 07:16 UTC
Investigating
FPX deposit system is having an emergency maintenance on 9th Nov from 2pm to 3pm. We hope to have this resolved soon with the bank and update as soon as the system is resumed
Posted Nov 09, 2021 - 06:24 UTC