Unable to buy or sell xStocks
Incident Report for
Luno
Resolved
No further issues from our last update, thanks again for your patience.
Posted
Oct
14
,
2025
-
06:42
UTC
Monitoring
This has been resolved, we're monitoring for any additional errors.
Posted
Oct
13
,
2025
-
16:05
UTC
Identified
Our team have identified the issue, some customers have been unable to buy or sell xStocks since aronud 04:00 UTC this morning, 13 October 2025.
This is ongoing, we're working on this as a priority.
Posted
Oct
13
,
2025
-
15:18
UTC
Investigating
We've investigating some issues affecting xStocks, customers may be unable to buy or sell xStocks.
Our teams are investigating as a priority.
Posted
Oct
13
,
2025
-
14:54
UTC
×
Subscribe to Incident
Subscribe to updates for
Unable to buy or sell xStocks
via . You'll receive .