Delayed Deposits and Withdrawals South Africa
Incident Report for Luno
Resolved
Deposits and withdrawals are now processing as normal.
Posted Aug 11, 2021 - 08:49 UTC
Update
We are currently experiencing a delay with the processing of deposits and withdrawals in South Africa. We are working on a fix as a priority and will update this status page as the situation progresses.
Posted Aug 10, 2021 - 16:07 UTC
Identified
We are currently experiencing a delay with the processing of withdrawals in South Africa. We are working on a fix as a priority and will update this status page as the situation progresses.
Posted Aug 10, 2021 - 14:15 UTC
This incident affected: Bank deposits and withdrawals (South Africa).