PayU Maintenance in South Africa
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Oct 09, 2020 - 07:41 UTC
Identified
One of our payments providers PayU have concluded their platform maintenance but we are still seeing errors. We are looking into this.

This may affect deposits through PayU on our app. Please use an alternative depositing method until the maintenance is complete.
Posted Oct 09, 2020 - 05:48 UTC