Instant Buy and Sell
Incident Report for Luno
Resolved
Instant Buy and Sell is back to normal. We expect no further interruptions.

Thanks for your patience.
Posted Aug 26, 2020 - 12:16 UTC
Identified
Instant Buy and Sell may be temporarily unavailable for some customers due to unscheduled maintenance. The exchange remains fully functional.

We don't expect this to last more than a few hours.
Posted Aug 26, 2020 - 11:28 UTC