Delayed bank withdrawal in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Nov 02, 2020 - 03:20 UTC
Identified
Withdrawals in Indonesia will not be processed on 28 - 30 October 2020 due to the public holidays. Unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 2 November 2020.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Oct 26, 2020 - 12:34 UTC