Slow account verification
Incident Report for Luno
Resolved
Account verification times have come down substantially, we'll let you know if that changes.
Posted Apr 02, 2020 - 16:04 UTC
Update
While the backlog has decreased we are still seeing longer than normal delays in verifying some customers. We're working through the remaining backlog of verifications as quickly as possible.
Posted Mar 31, 2020 - 09:47 UTC
Identified
Some customers may experience slower than normal account verifications for level 2 and 3, this means that there may be delays in increasing your bank deposit/withdrawal limits.

We’re working through the backlog as quickly as possible.
Posted Mar 24, 2020 - 06:34 UTC