Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
The majority of withdrawals are being processed as normal, however some may see a delay and be processed the next business day.

Our team are working on a way to permanently resolve this.
Posted 21 days ago. Mar 29, 2019 - 12:16 UTC
Identified
Due to an error with the bank some withdrawal batches have not yet been processed. This is a temporary incident which we hope to see resolved tomorrow.

Some Nigerian customers may see a delay with bank withdrawals requested on 25 March 2019. Our team are working hard to get these processed as soon as possible.

We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022934
Posted 25 days ago. Mar 25, 2019 - 15:49 UTC