Bank deposits and withdrawals in South Africa
Incident Report for Luno
Resolved
FNB have resolved the technical issues, deposits and withdrawals are being processed as normal.
Posted 11 months ago. Dec 01, 2017 - 13:54 UTC
Identified
Due to a technical issue with FNB in South Africa, deposits and withdrawals to and from our FNB bank account are currently delayed.
Our team is aware of the issue and is working closely with the bank to see this resolved as quickly as possible.

Updates to follow.
Posted 11 months ago. Dec 01, 2017 - 09:50 UTC