Slow bank withdrawals in South Africa
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 22 days ago. Aug 26, 2019 - 14:03 SAST
Identified
There will be a slight delay with South African bank account withdrawals requested on 26 August 2019. This is a temporary incident which we hope to see resolved during the day. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022934

Updates to follow.
Posted 22 days ago. Aug 26, 2019 - 11:31 SAST