Delayed account verification in South Africa
Incident Report for Luno
Resolved
The issue has been fixed and our provider is fully operational.
Posted Nov 18, 2021 - 08:45 UTC
Monitoring
We have managed to recover and we are performing account verification at an optimal level. Our service provider has recovered and we are continuing to monitor to ensure everything is fully operational.
Posted Nov 18, 2021 - 05:37 UTC
Investigating
We are experiencing an issue with our identity provider, which is resulting in a delay in getting account verification completed for all new customers in South Africa. Our team are working to fix this issue promptly
Posted Nov 18, 2021 - 05:25 UTC
This incident affected: Help & account verification (Account verification).