Delayed bank withdrawal in Indonesia
Incident Report for Luno
Resolved
Withdrawals are now being processed as scheduled. Thank you
Posted Apr 05, 2021 - 02:55 UTC
Identified
Certain withdrawals in Indonesia will not be processed on 2 April 2021 due to the public holiday, unfortunately, banks do not process these withdrawals over weekends or public holidays.

Kindly expect some delay in your withdrawals during this time.

For more information, please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Mar 31, 2021 - 04:31 UTC
This incident affected: Bank deposits and withdrawals (Indonesia).