Instant Buy and Sell for Ethereum in Europe
Incident Report for Luno
Resolved
Instant Buy and Sell orders for Ethereum are processing as normal.
Posted 6 months ago. Feb 19, 2018 - 16:08 UTC
Identified
Some customers may have issues using the Instant Buy and Sell functionality for Ethereum orders.
Our team are aware of this and working on a fix. Trades via the Exchange are still available, this is accessible via https://www.luno.com/trade/ETHXBT

Updates to follow.
Posted 6 months ago. Feb 19, 2018 - 15:54 UTC