Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
We have resolved the issue and withdrawals should be processed during the next release.

You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934
Posted Jun 16, 2021 - 12:55 UTC
Identified
There will be temporary delays with processing Malaysia withdrawals on 16th June. We're investigating the issue and will come up with a fix soon.
Posted Jun 16, 2021 - 02:23 UTC