Email ticket and chat support issues
Incident Report for Luno
Resolved
Support ticket creation and live chat services are both working optimally without interruption. Thank you for your patience while we fixed the issue.
Posted Dec 14, 2021 - 09:26 UTC
Monitoring
We're seeing an improvement in ticket and chat creation. There should be minimal to no errors experienced when customers attempt to make contact with us through these channels. We will continue to monitor and keep you updated. Thank you for your patience.
Posted Dec 14, 2021 - 08:30 UTC
Investigating
We are currently experiencing sporadic issues with support ticket creation and our live chat facilities. Customers might see some errors when attempting to contact us. We are working on fixing the issue as promptly as possible and we apologize for any inconvenience caused.
Posted Dec 14, 2021 - 07:22 UTC
This incident affected: Help & account verification (Support response times).