Issues signing in via Web
Incident Report for Luno
Resolved
All services have returned to normal.
Posted 2 months ago. Aug 06, 2019 - 16:44 SAST
Investigating
Our team has identified an issue affecting sign ins using Email address and password, this means customers who use email to sign into their Luno account may be unable to do so.

Google and Facebook sign ins remain unaffected.
Posted 2 months ago. Aug 06, 2019 - 16:32 SAST
This incident affected: Website.