Delayed withdrawals for FNB in South Africa
Incident Report for Luno
Resolved
This incident has been resolved.
Posted 8 months ago. Jan 29, 2018 - 08:08 UTC
Investigating
There will be a slight delay on FNB withdrawals requested on 26.01.2018. This is due to the necessity to process withdrawals via a different bank while FNB online banking is temporarily unavailable. We apologise for any inconvenience.
Posted 8 months ago. Jan 26, 2018 - 14:10 UTC