Delayed Deposits In Nigeria

Incident Report for Luno

Resolved

The issue has been resolved, thank you for your patience.
Posted May 18, 2026 - 09:15 UTC

Identified

Customers in Nigeria are unable to initiate deposits. This is due to an issue caused by our third party.

We are working to resolve the issue as a priority with our third party.

Thank you for your patience and we apologise for the inconvenience caused.
Posted May 17, 2026 - 22:08 UTC