Account verification delays in Nigeria
Incident Report for Luno
Resolved
Verification times have returned to normal.
Posted 16 days ago. May 10, 2019 - 10:50 UTC
Investigating
Customers in Nigeria waiting to be verified to Level 1 may experience slower than normal verification times. This is due to our third party verification service being down.

We're currently communicating with them to see this resolved as quickly as possible.

Our team will have all Nigerian customers verified as soon as possible.
Posted 19 days ago. May 07, 2019 - 08:23 UTC