Delayed bank deposits in Australia
Incident Report for Luno
Resolved
The planned outage on the 21st of March 2021 has been cancelled by our banking partner.

There will be no interruption to deposits and PayID registration during this time.

Thank you.
Posted Mar 19, 2021 - 10:56 UTC
Identified
Our banking partner in Australia will be undergoing critical system maintenance at these times:
Start: 21 March 2021 @ 02:00am AEDT
End: 21 March 2021 @ 06:00am AEDT

During this window, Instant Bank Transfers and PayID deposits including PayID registration will be unavailable. Please do not make deposits during this time to avoid unsuccessful payments.

Thanks for your patience.
Posted Mar 18, 2021 - 09:02 UTC
This incident affected: Bank deposits and withdrawals (Australia).