Bank withdrawals in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 3 months ago. Aug 02, 2018 - 07:00 UTC
Identified
Bank withdrawals are unfortunately being delayed due to a technical issue.

Updates to follow.
Posted 3 months ago. Jul 31, 2018 - 14:01 UTC