Bank withdrawals stuck in processing in South Africa
Incident Report for Luno
Resolved
Bank withdrawals are being processed as normal.
Posted Dec 04, 2021 - 12:46 UTC
Monitoring
The processing withdrawal numbers are starting to come down, we're monitoring closely for any further anomalies.
Posted Dec 04, 2021 - 09:45 UTC
Identified
Our team has identified some bank withdrawals stuck in a processing state, withdrawals have been cleared at the bank however will display as processing on your ZAR wallet. This means that customers who have processing withdrawals unfortunately won't be able to request another withdrawal.

We're working on a fix for this.
Posted Dec 04, 2021 - 09:03 UTC