BCH Instant Buy and Sell temporarily unavailable
Incident Report for Luno
Resolved
BCH Instant Buy and Sell is available again, thanks for your patience.
Posted Oct 28, 2019 - 17:08 SAST
Identified
Our team have identified an issue where BCH buys and sells placed via Instant Buy and Sell are taking longer than normal to be credited to other wallets. All orders will still be honoured however there may be a delay in completing the order.

Updates to follow.
Posted Oct 28, 2019 - 13:26 SAST