Slow Bitcoin Sends
Incident Report for Luno
Resolved
Bitcoin send times have returned to normal.
Posted 2 months ago. Oct 04, 2018 - 09:24 UTC
Identified
Some BTC send transactions are being reported as slow, our team is aware of the issue and are working on a fix.

Please check back to your transaction state in the Wallets section to monitor your transaction. Once the transaction is marked as processing it means that the transaction is in the process of being sent. A send transaction can be cancelled if it is still in a pending state.
Posted 2 months ago. Oct 04, 2018 - 06:29 UTC
This incident affected: Bitcoin sends and receives.