Support ticket delays
Incident Report for Luno
Resolved
The incident has been resolved and delays in responses are processed as normal.
Posted 7 months ago. Feb 12, 2019 - 15:50 SAST
Identified
Customers contacting Luno may receive a delayed response as the description of the mail is not displaying correctly on our system. Our team are aware of this and are actively working towards a fix.

We may respond to the ticket asking you to re-send your initial question - apologies for any inconvenience caused.
Posted 7 months ago. Feb 12, 2019 - 12:13 SAST