Delayed bank deposits in Australia
Incident Report for Luno
Resolved
This issue has been resolved. Thank you.
Posted Dec 22, 2020 - 05:49 UTC
Investigating
There may be temporary delays with deposits for new accounts that are created in Australia.

Our team are investigating urgently.

Updates to follow.
Posted Dec 21, 2020 - 18:12 UTC