Delayed withdrawals in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal, if you do see a withdrawal process slower than usual please reach out to our team.
Posted Apr 15, 2024 - 07:48 UTC
Identified
We're seeing slower than normal MYR withdrawals in Malaysia.
Updates to follow.
Posted Apr 15, 2024 - 04:35 UTC