Delayed bank withdrawal in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed according to schedule.

Thank you.
Posted Jun 10, 2020 - 05:34 UTC
Identified
Withdrawals in Malaysia will not be processed on 8th of June due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 9th of June.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Jun 05, 2020 - 08:12 UTC