Delayed bank transfer deposits and withdrawal in Malaysia
Incident Report for Luno
Resolved
Deposits and withdrawals are now processed accordingly.
Posted Mar 22, 2024 - 02:21 UTC
Monitoring
A fix has been implemented by the banking partner and we are monitoring.
Posted Mar 21, 2024 - 07:22 UTC
Investigating
There are temporary delays with deposits and withdrawals due to unexpected technical issues faced by our banking partner. We're working closely with the bank to see this resolved soon.

In the meantime, please make use of an alternative deposit method FPX and Touch 'n Go.

Thank you for your understanding.
Posted Mar 20, 2024 - 16:01 UTC