Instant Buy and Sell in Zambia
Incident Report for Luno
Resolved
The market in Zambia is looking more liquid, Instant Buy and Sell should be available per normal.
Please reach out to our team should there continue to be any errors.

Thanks for your patience.
Posted Jun 10, 2020 - 09:29 UTC
Identified
Instant Buy and Sell may be unavailable for some customers in Zambia, please make use of the Exchange until the market can resolve the liquidity shortage.

For more information on how the Exchange works, follow the links below to our Help Centre:
https://www.luno.com/help/articles/1000172902
https://www.luno.com/help/articles/11000001992

Thanks for your patience.
Posted May 29, 2020 - 15:00 UTC