Bitcoin Cash(BCH) sends are unavailable
Incident Report for
Luno
Resolved
Update:
We can confirm BCH sends are being processed and completed.
We appreciate your patience and understanding in this matter.
Posted
Oct
14
,
2025
-
06:31
UTC
Update
Update:
Our team is still working on this issue as a priority.
Customers attempting to send BCH to another platform from Luno may encounter an error, and the send will be cancelled.
We apologise for any inconvenience caused.
Posted
Oct
13
,
2025
-
13:42
UTC
Identified
We have identified an issue that is affecting BCH sends.
Customers attempting to send BCH out of Luno’s platform may encounter an error, and the send will be cancelled.
Our team has identified the issue and is working on it as a priority.
We apologise for any inconvenience caused.
Posted
Oct
13
,
2025
-
07:32
UTC
×
Subscribe to Incident
Subscribe to updates for
Bitcoin Cash(BCH) sends are unavailable
via . You'll receive .