Bank account linking and deposits unavailable via Stitch in South Africa
Incident Report for Luno
Resolved
The issue preventing South African customers from linking bank accounts and making deposits via Stitch has been resolved. Thank you for your patience.
Posted Apr 23, 2024 - 13:08 UTC
Monitoring
Our team has implemented a fix, and customers can now link new bank accounts to their Luno accounts and deposit funds via Stitch without any issues. Thank you for your patience.
Posted Apr 23, 2024 - 11:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 23, 2024 - 11:13 UTC
Update
We are continuing to investigate this issue.
Posted Apr 23, 2024 - 11:01 UTC
Investigating
We are currently investigating an issue that is preventing South African customers from linking new bank accounts to their Luno accounts. Additionally, deposits via Stitch are also unavailable. We will provide updates shortly.
Posted Apr 23, 2024 - 10:58 UTC