Staking delays

Incident Report for Luno

Resolved

The issue has been resolved. We are no longer seeing staking delays.

Thank you for your your patience.
Posted Oct 15, 2025 - 06:51 UTC

Update

We are no longer experiencing delays in rewards being paid out. Customers are getting their rewards daily, however there are still delays in our DOT staking and our team is working hard on fixing the issue.
Posted Oct 07, 2025 - 09:54 UTC

Identified

Apologies for our confusing updates, from our last update on https://status.luno.com/incidents/n40yjqrvd1s9 we're still experiencing some delays.

While NEAR staking was affected around 25 September 2025, rewards there have been resolved.
We're still seeing some delays with DOT staking which our team are actively working towards. Some customers may see delays with their payout rewards for DOT, the last pay out for most customers was around 25 September 2025.

We're working on this as a priority, very sorry about the issues that this has caused. Updates to follow, thanks for your patience.
Posted Oct 03, 2025 - 10:50 UTC