Delayed account verification and email response times
Incident Report for Luno
Resolved
While we continue to see unprecedented contact volumes and sign ups we're making good strides to lessen the backlog of account verifications and email turn around times. This is a company wide priority that we're taking very seriously, of which we're already starting to see good results.

Various improvements have been implemented internally to better prioritise our queues along with a more detailed initial response when sending us a query.

A huge thanks again for everyone's patience.
Posted Jun 05, 2020 - 16:50 UTC
Identified
We are currently facing extremely high contact volumes along with an increased number of sign ups. This results in slower response and longer account verification times.

We cannot provide a clear timeline when your request will be resolved but we are working hard to provide the most effective support in these extraordinary circumstances.

Before sending a support request we encourage you to please view our extensive Help Centre - https://www.luno.com/help

If you’re unable to find a solution on our Help Centre please send us as much information as possible so we can assist you in the most efficient way possible.

In order to have your account verified automatically please submit the correct information and upload accepted documents - https://www.luno.com/wallet/settings/identity

Read more about verification here - https://www.luno.com/help/en/articles/11000019400

Continuous updates will be provided here.
Posted May 05, 2020 - 11:49 UTC