Delayed bank withdrawal in Indonesia
Incident Report for Luno
Resolved
Withdrawal payments are being processed according to our published schedule.
Posted Mar 26, 2020 - 07:07 UTC
Identified
Some withdrawals in Indonesia will not be processed on March 25, 2020 due to the public holiday. Unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on March 26, 2020.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Mar 25, 2020 - 13:54 UTC